initialize MethodStatic

Called by the application to initialize the UiFramework. Also initializes UiComponents, UiCore and UiAbstract.

initialize(store: undefined | Store<any, AnyAction>, i18n?: I18N, frameworkStateKey?: string): Promise<void>

Parameter Type Description
store undefined | Store<any, AnyAction> The single Redux store created by the host application. If this is undefined then it is assumed that the StateManager is being used to provide the Redux store.
i18n I18N The internationalization service created by the application. Defaults to IModelApp.i18n.
frameworkStateKey string The name of the key used by the app when adding the UiFramework state into the Redux store. If not defined "frameworkState" is assumed. This value is ignored if StateManager is being used. The StateManager use "frameworkState".

Returns - Promise<void>

Defined in

Last Updated: 29 November, 2022