DefaultNavigationWidget Class

Beta  @deprecated use BasicNavigationWidget instead

Default Navigation Widget for zone 3. Provides standard view manipulation tools and displays registered Navigation Aids as corner item. This definition will also show a overflow button if there is not enough room to display all the toolbar buttons.

Extends

Methods

Name Description
constructor(props: Readonly<DefaultNavigationProps>): DefaultNavigationWidget    
constructor(props: DefaultNavigationProps, context?: any): DefaultNavigationWidget    
render(): Element    

Defined in

Last Updated: 29 November, 2022