WidgetManager Class

Beta  

Widget Manager class.

Methods

Name Description
constructor(): WidgetManager    
addWidgetDef(widgetDef: WidgetDef, stageId: undefined | string, stageUsage: undefined | string, location: ZoneLocation | StagePanelLocation, section?: StagePanelSection): boolean Adds a WidgetDef for use in a Frontstage.  
addWidgetProvider(widgetProvider: WidgetProvider): void Adds a WidgetDef Provider  
getWidgetDefs(stageId: string, stageUsage: string, location: ZoneLocation | StagePanelLocation, section?: StagePanelSection): undefined | Gets WidgetDefs for a Frontstage location.  
removeWidgetDef(widgetId: string): boolean Removes a WidgetDef.  
removeWidgetProvider(providerId: string): boolean Removes a WidgetDef Provider  

Defined in

Last Updated: 29 November, 2022