ToolSettingsPopupProps Interface

Beta  

Properties of ToolSettingsPopup component.

Extends

Methods

Name Description
onClose(): void Optional Function called when the popup is closed.  

Properties

Name Type Description
children undefined | ReactNode Popup content.  
isOpen undefined | boolean Describes if the popup is open.  
target | HTMLElement Popup target.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022