SnapModeProps Interface

Beta  

Properties of SnapMode component.

Extends

Methods

Name Description
onClick(): void Optional Function called when indicator is clicked.  

Properties

Name Type Description
children undefined | string Indicator label.  
icon undefined | ReactNode Indicator icon.  
indicatorRef undefined | Ref<HTMLDivElement> Clickable part of the indicator.  

Inherited properties

Name Type Inherited from Description
className undefined | string FooterIndicatorProps Custom CSS class name
isInFooterMode undefined | boolean FooterIndicatorProps Describes whether the footer is in footer or widget mode.
style undefined | CSSProperties FooterIndicatorProps Custom CSS style properties
title undefined | string FooterIndicatorProps Title for the indicator

Defined in

Last Updated: 29 November, 2022