ZoneProps Interface

Beta  

Properties of Zone component.

Extends

Properties

Name Type Description
bounds undefined | RectangleProps Zone bounds.  
children undefined | ReactNode Zone content.  
id WidgetZoneId Zone id.  
isFloating undefined | boolean Describes if the zone is floating.  
isHidden undefined | boolean Describes if the zone is hidden.  
isInFooterMode undefined | boolean Describes if the zone is in footer mode.  
safeAreaInsets undefined | SafeAreaInsets Describes respected safe area insets.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022