Symbology

Types that define the appearance of geometry.

Classes

Name Description  
ColorDef An integer representation of a color.  
FontMap A FontMap holds the table of known fonts available in an iModel.  
GeometryParams Describes the display properties of graphics in a persistent element's GeometryStream that aren't inherited from SubCategoryAppearance.  
GraphicParams The "cooked" material and symbology for a RenderGraphic. Beta
HSLColor A color defined by Hue, Saturation, and Lightness.  
HSVColor A color defined by Hue, Saturation, and Value  
RgbColor An immutable representation of a color with red, green, and blue components each in the integer range [0, 255].  
SubCategoryAppearance Parameters that define the way geometry on a SubCategory appears.  

Enumerations

Name Description  
BackgroundFill Describes how a view's background color affects the interior area of a closed region.  
ColorByName A set of known colors by name, as a 32-bit integer in the form 0xBBGGRR (red is the low byte).  
FillDisplay Whether a closed region should be drawn for wireframe display with its internal area filled or not.  
FillFlags Flags indicating whether and how the interiors of closed planar regions is displayed within a view.  
FontType The type of a font.  
GeometryClass Categorizes a piece of geometry within a GeometryStream.  
LinePixels Enumerates the available patterns for drawing patterned lines.  

Interfaces

Name Description  
FontMapProps The properties of a FontMap  
FontProps The properties of a Font.  
SubCategoryAppearance.Props Properties used to create a SubCategoryAppearance  

Namespaces

Name Description  
AreaPattern  
Gradient Beta
LineStyle  

Type Aliases

Name Description  
ColorDefProps A number in 0xTTBBGGRR format  
RgbColorProps JSON representation of an RgbColor  

Last Updated: 05 June, 2020