TreeNode<S, SS, S> Class

Default component for rendering a node for the Tree

Extends

Methods

Name Description
constructor(props: TreeNodeProps): TreeNode    
componentDidUpdate(_prevProps: TreeNodeProps): void    
render(): Element    
shouldComponentUpdate(nextProps: TreeNodeProps): boolean    

Inherited methods

Name Inherited from Description
UNSAFE_componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
UNSAFE_componentWillReceiveProps(nextProps: Readonly<TreeNodeProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
UNSAFE_componentWillUpdate(nextProps: Readonly<TreeNodeProps>, nextState: Readonly<S>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional ComponentLifecycle Catches exceptions generated in descendant components.
componentDidMount(): void Optional ComponentLifecycle Called immediately after a component is mounted.
componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
componentWillReceiveProps(nextProps: Readonly<TreeNodeProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
componentWillUnmount(): void Optional ComponentLifecycle Called immediately before a component is destroyed.
componentWillUpdate(nextProps: Readonly<TreeNodeProps>, nextState: Readonly<S>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
forceUpdate(callback?: () => void): void Component<TreeNodeProps>  
getSnapshotBeforeUpdate(prevProps: Readonly<TreeNodeProps>, prevState: Readonly<S>): SS | null Optional NewLifecycle Runs before React applies the result of render to the document, and
setState<K extends undefined>(state: (prevState: Readonly<S>, props: Readonly<TreeNodeProps>) => null | S | object | null | S | object, callback?: () => void): void Component<TreeNodeProps>  

Inherited properties

Name Type Inherited from Description
context any Component<TreeNodeProps> If using the new style context, re-declare this in your class to be the
contextType Static undefined | Context<any> Component<TreeNodeProps> If set, this.context will be set at runtime to the current value of the given Context.
props undefined Component<TreeNodeProps>  
refs [key: string]: ReactInstance Component<TreeNodeProps>  
state Readonly<S> Component<TreeNodeProps>  

Defined in

Last Updated: 05 June, 2020