BrowserAuthorizationClient Class

Beta  

Extends

Implements

Methods

Name Description
constructor(configuration: BrowserAuthorizationClientConfiguration): BrowserAuthorizationClient    
_onAccessTokenExpired(): void Protected Raised after the access token has expired.  
_onAccessTokenExpiring(): Promise<void> Protected Raised prior to the access token expiring  
_onSilentRenewError(): void Protected Raised when the automatic silent renew has failed.  
_onUserLoaded(user: User): void Protected Raised when a user session has been established (or re-established).  
_onUserSignedOut(): void Protected Raised when the user's sign-in status at the OP has changed.  
_onUserStateChanged(user: undefined | User): void Protected    
_onUserUnloaded(): void Protected Raised when a user session has been terminated.  
checkSessionStatus(requestContext: ClientRequestContext): Promise<boolean> Checks the current local user session against that of the identity provider.  
createUserManager(settings: UserManagerSettings): UserManager Protected Creates the internal user manager and binds all relevant events to their respective callback function.  
dispose(): void Disposes the resources held by this client  
getAccessToken(requestContext?: ClientRequestContext): Promise<AccessToken> Returns a promise that resolves to the AccessToken of the currently authorized user.  
getUserManager(requestContext: ClientRequestContext): Promise<UserManager> Protected    
getUserManagerSettings(requestContext: ClientRequestContext, basicSettings: BrowserAuthorizationClientConfiguration, advancedSettings?: UserManagerSettings): Promise<UserManagerSettings> Protected Merges the basic and advanced settings into a single configuration object consumable by the internal userManager.  
initAccessToken(user: undefined | User): void Protected    
loadUser(requestContext: ClientRequestContext): Promise<undefined | User> Protected Gets the user from storage  
nonInteractiveSignIn(requestContext: ClientRequestContext, args?: BrowserAuthorizationClientRequestOptions): Promise<undefined | User> Protected Attempts a non-interactive signIn  
Alias for signInRedirect needed to satisfy FrontendAuthorizationClient  
signInPopup(requestContext: ClientRequestContext, args?: BrowserAuthorizationClientRequestOptions): Promise<void> Attempts a sign-in via popup with the authorization provider  
signInRedirect(requestContext: ClientRequestContext, successRedirectUrl?: string, args?: BrowserAuthorizationClientRequestOptions): Promise<void> Attempts a sign-in via redirection with the authorization provider.  
signInSilent(requestContext: ClientRequestContext): Promise<void> Attempts a silent sign in with the authorization provider  
signOut(requestContext?: ClientRequestContext): Promise<void> Alias for signOutRedirect  
signOutPopup(requestContext: ClientRequestContext): Promise<void>    
signOutRedirect(requestContext: ClientRequestContext): Promise<void>    

Properties

Name Type Description
_accessToken Protected undefined | AccessToken    
hasExpired Accessor ReadOnly boolean    
hasSignedIn Accessor ReadOnly boolean Set to true if signed in - the accessToken may be active or may have expired and require a refresh  
isAuthorized Accessor ReadOnly boolean is the user currently authorized?  
onUserStateChanged Readonly BeEvent<(token?: AccessToken) => void> Event called when the user's sign-in state changes - this may be due to calls to signIn(), signOut() or simply because the token expired  

Inherited properties

Name Type Inherited from Description
_advancedSettings Protected undefined | UserManagerSettings BrowserAuthorizationBase  
_basicSettings Protected BrowserAuthorizationClientConfiguration BrowserAuthorizationBase  
_userManager Protected undefined | UserManager BrowserAuthorizationBase  

Defined in

Last Updated: 29 November, 2022