IModelBaseHandler Class

This class acts as the WsgClient for other iModelHub Handlers.

Extends

Methods

Name Description
delete(requestContext: AuthorizedClientRequestContext, relativeUrlPath: string, httpRequestOptions?: HttpRequestOptions): Promise<void> Send a delete request.  
deleteInstance<T extends WsgInstance<T>>(requestContext: AuthorizedClientRequestContext, relativeUrlPath: string, instance?: T, requestOptions?: WsgRequestOptions): Promise<void> Delete a strongly typed instance.  
getInstances<T extends WsgInstance<T>>(requestContext: AuthorizedClientRequestContext, typedConstructor: () => T, relativeUrlPath: string, queryOptions?: RequestQueryOptions, httpRequestOptions?: HttpRequestOptions): Promise<T[]> Get multiple strongly typed instances.  
getInstancesChunk<T extends WsgInstance<T>>(requestContext: AuthorizedClientRequestContext, url: string, chunkedQueryContext: undefined | ChunkedQueryContext, typedConstructor: () => T, queryOptions?: RequestQueryOptions, httpRequestOptions?: HttpRequestOptions): Promise<T[]> Get a chunk of strongly typed instances.  
postInstance<T extends WsgInstance<T>>(requestContext: AuthorizedClientRequestContext, typedConstructor: () => T, relativeUrlPath: string, instance: T, requestOptions?: WsgRequestOptions, httpRequestOptions?: HttpRequestOptions): Promise<T> Post a strongly typed instance.  
postInstances<T extends WsgInstance<T>>(requestContext: AuthorizedClientRequestContext, typedConstructor: () => T, relativeUrlPath: string, instances: T[], requestOptions?: WsgRequestOptions, httpRequestOptions?: HttpRequestOptions): Promise<T[]> Post multiple strongly typed instances.  
postQuery<T extends WsgInstance<T>>(requestContext: AuthorizedClientRequestContext, typedConstructor: () => T, relativeUrlPath: string, queryOptions: RequestQueryOptions, httpRequestOptions?: HttpRequestOptions): Promise<T[]> Get multiple strongly typed instances.  
use(func: HttpRequestOptionsTransformer): void Adds a method that will be called for every request to modify HttpRequestOptions. Beta  

Inherited methods

Name Inherited from Description
applyUserConfiguredHttpRequestOptions(requestOptions: RequestOptions, userDefinedRequestOptions?: HttpRequestOptions): void Protected WsgClient Configures request options based on user defined values in HttpRequestOptions

Properties

Name Type Description
_agent Protected any    
_fileHandler Protected undefined | FileHandler    
_url Protected undefined | string    
configRelyingPartyUri StaticReadonly "imjs_imodelhub_relying_party_uri"    

Inherited properties

Name Type Inherited from Description
apiVersion string WsgClient  
baseUrl Protected undefined | string WsgClient Sets the default base URL to use with this client.
configHostRelyingPartyUri StaticReadonly "imjs_default_relying_party_uri" WsgClient  
configUseHostRelyingPartyUriAsFallback StaticReadonly "imjs_use_default_relying_party_uri_as_fallback" WsgClient  

Defined in

Last Updated: 29 November, 2022