IModelHubClient Class

Class that allows access to different iModelHub class handlers. Handlers should be accessed through an instance of this class, rather than constructed directly.

Extends

Methods

Name Description
constructor(fileHandler?: FileHandler, iModelBaseHandler: IModelBaseHandler = ..., applicationVersion?: string): IModelHubClient Create an instance of IModelHubClient.  

Inherited methods

Name Inherited from Description
setFileHandler(fileHandler: FileHandler): void IModelClient Sets file handler for file upload/download.
use(transformer: HttpRequestOptionsTransformer): void IModelClient Adds a method that will be called for every request to modify HttpRequestOptions.

Inherited properties

Name Type Inherited from Description
_handler Protected IModelBaseHandler IModelClient  
changeSets Accessor ReadOnly ChangeSetHandler IModelClient Get the handler for ChangeSets.
events Accessor ReadOnly EventHandler IModelClient Get the handler for IModelHubEvents.
fileHandler Accessor ReadOnly undefined | FileHandler IModelClient Gets file handler for file upload/download.
iModel Accessor ReadOnly IModelHandler IModelClient Get the handler for HubIModel.
iModels Accessor ReadOnly IModelsHandler IModelClient Get the handler for HubIModel instances.
thumbnails Accessor ReadOnly ThumbnailHandler IModelClient Get the handler for Thumbnails.
users Accessor ReadOnly UserInfoHandler IModelClient Get the handler for UserInfo.
versions Accessor ReadOnly VersionHandler IModelClient Get the handler for Versions.

Defined in

Last Updated: 29 November, 2022