saveChanges Method
Commit pending changes to this iModel.
saveChanges(description?: string): void
note If this IModelDb is a briefcase that is synchronized with iModelHub, then you must call ConcurrencyControl.request before attempting to save changes.
throws IModelError if there is a problem saving changes or if there are pending, un-processed lock or code requests.
Parameter | Type | Description |
---|---|---|
description | string | Optional description of the changes |
Returns - void
Defined in
- core/backend/src/IModelDb.ts Line 709
Last Updated: 11 June, 2024