TemplateModelCloner Class

Beta  

IModelTransformer that clones the contents of a template model.

Extends

Methods

Name Description
constructor(sourceDb: IModelDb, targetDb: IModelDb = sourceDb): TemplateModelCloner Construct a new TemplateModelCloner  
onTransformElement(sourceElement: Element): ElementProps Protected Cloning from a template requires this override of onTransformElement.  
placeTemplate2d(sourceTemplateModelId: string, targetModelId: string, placement: Placement2d): Promise<Map<string, string>> Place a template from the sourceDb at the specified placement in the target model within the targetDb.  
placeTemplate3d(sourceTemplateModelId: string, targetModelId: string, placement: Placement3d): Promise<Map<string, string>> Place a template from the sourceDb at the specified placement in the target model within the targetDb.  

Inherited methods

Name Inherited from Description
detectElementDeletes(): Promise<void> IModelTransformer Detect Element deletes using ExternalSourceAspects in the target iModel and a brute force comparison against Elements in the source iModel.
detectRelationshipDeletes(): Promise<void> IModelTransformer Detect Relationship deletes using ExternalSourceAspects in the target iModel and a brute force comparison against relationships in the source iModel.
dispose(): void IModelTransformer Dispose any native resources associated with this IModelTransformer.
hasElementChanged(sourceElement: Element, targetElementId: string): boolean Protected IModelTransformer Returns true if a change within sourceElement is detected.
initFromExternalSourceAspects(): void IModelTransformer Initialize the source to target Element mapping from ExternalSourceAspects in the target iModel.
onDeleteElement(sourceElementId: string): void Protected IModelTransformer Override of IModelExportHandler.onDeleteElement that is called when IModelExporter detects that an Element has been deleted from the source iModel.
onDeleteModel(_sourceModelId: string): void Protected IModelTransformer Override of IModelExportHandler.onDeleteModel that is called when IModelExporter detects that a Model has been deleted from the source iModel.
onDeleteRelationship(sourceRelInstanceId: string): void Protected IModelTransformer Override of IModelExportHandler.onDeleteRelationship that is called when IModelExporter detects that a Relationship has been deleted from the source iModel.
onExportCodeSpec(sourceCodeSpec: CodeSpec): void Protected IModelTransformer Override of IModelExportHandler.onExportCodeSpec that imports a CodeSpec into the target iModel when it is exported from the source iModel.
onExportElement(sourceElement: Element): void Protected IModelTransformer Override of IModelExportHandler.onExportElement that imports an element into the target iModel when it is exported from the source iModel.
onExportElementMultiAspects(sourceAspects: ElementMultiAspect[]): void Protected IModelTransformer Override of IModelExportHandler.onExportElementMultiAspects that imports ElementMultiAspects into the target iModel when they are exported from the source iModel.
onExportElementUniqueAspect(sourceAspect: ElementUniqueAspect): void Protected IModelTransformer Override of IModelExportHandler.onExportElementUniqueAspect that imports an ElementUniqueAspect into the target iModel when it is exported from the source iModel.
onExportFont(font: FontProps, _isUpdate: undefined | boolean): void Protected IModelTransformer Override of IModelExportHandler.onExportFont that imports a font into the target iModel when it is exported from the source iModel.
onExportModel(sourceModel: Model): void Protected IModelTransformer Override of IModelExportHandler.onExportModel that is called when a Model should be exported from the source iModel.
onExportRelationship(sourceRelationship: Relationship): void Protected IModelTransformer Override of IModelExportHandler.onExportRelationship that imports a relationship into the target iModel when it is exported from the source iModel.
onExportSchema(schema: Schema): Promise<void> Protected IModelTransformer Override of IModelExportHandler.onExportSchema that serializes a schema to disk for IModelTransformer.processSchemas to import into
onProgress(): Promise<void> Protected IModelTransformer This method is called when IModelExporter has made incremental progress based on the IModelExporter.progressInterval setting.
onTransformElementAspect(sourceElementAspect: ElementAspect, _targetElementId: string): ElementAspectProps Protected IModelTransformer Transform the specified sourceElementAspect into ElementAspectProps for the target iModel.
onTransformModel(sourceModel: Model, targetModeledElementId: string): ModelProps Protected IModelTransformer Transform the specified sourceModel into ModelProps for the target iModel.
onTransformRelationship(sourceRelationship: Relationship): RelationshipProps Protected IModelTransformer Transform the specified sourceRelationship into RelationshipProps for the target iModel.
processAll(): Promise<void> IModelTransformer Export everything from the source iModel and import the transformed entities into the target iModel.
processChanges(requestContext: AuthorizedClientRequestContext, startChangesetId?: string): Promise<void> IModelTransformer Export changes from the source iModel and import the transformed entities into the target iModel.
processChildElements(sourceElementId: string): Promise<void> IModelTransformer Import child elements into the target IModelDb
processCodeSpec(codeSpecName: string): Promise<void> IModelTransformer Cause a single CodeSpec to be exported from the source iModel and imported into the target iModel.
processCodeSpecs(): Promise<void> IModelTransformer Cause all CodeSpecs to be exported from the source iModel and imported into the target iModel.
processDeferredElements(numRetries: number = 3): Promise<void> IModelTransformer Import elements that were deferred in a prior pass.
processElement(sourceElementId: string): Promise<void> IModelTransformer Cause the specified Element and its child Elements (if applicable) to be exported from the source iModel and imported into the target iModel.
processFonts(): Promise<void> IModelTransformer Cause all fonts to be exported from the source iModel and imported into the target iModel.
processModel(sourceModeledElementId: string): Promise<void> IModelTransformer Cause the model container, contents, and sub-models to be exported from the source iModel and imported into the target iModel.
processModelContents(sourceModelId: string, targetModelId: string, elementClassFullName: string = Element.classFullName): Promise<void> IModelTransformer Cause the model contents to be exported from the source iModel and imported into the target iModel.
processRelationships(baseRelClassFullName: string): Promise<void> IModelTransformer Imports all relationships that subclass from the specified base class.
processSchemas(requestContext: AuthorizedClientRequestContext | ClientRequestContext): Promise<void> IModelTransformer Cause all schemas to be exported from the source iModel and imported into the target iModel.
processSubject(sourceSubjectId: string, targetSubjectId: string): Promise<void> IModelTransformer Recursively import all Elements and sub-Models that descend from the specified Subject
shouldExportCodeSpec(_sourceCodeSpec: CodeSpec): boolean Protected IModelTransformer Override of IModelExportHandler.shouldExportCodeSpec that is called to determine if a CodeSpec should be exported from the source iModel.
shouldExportElement(_sourceElement: Element): boolean Protected IModelTransformer Override of IModelExportHandler.shouldExportElement that is called to determine if an element should be exported from the source iModel.
shouldExportElementAspect(_sourceAspect: ElementAspect): boolean Protected IModelTransformer Override of IModelExportHandler.shouldExportElementAspect that is called to determine if an ElementAspect should be exported from the source iModel.
shouldExportRelationship(_sourceRelationship: Relationship): boolean Protected IModelTransformer Override of IModelExportHandler.shouldExportRelationship that is called to determine if a Relationship should be exported.
shouldExportSchema(schemaKey: SchemaKey): boolean Protected IModelTransformer Override of IModelExportHandler.shouldExportSchema that is called to determine if a schema should be exported
skipElement(sourceElement: Element): void Protected IModelTransformer Mark the specified Element so its processing can be deferred.

Inherited properties

Name Type Inherited from Description
_deferredElementIds Protected Set<string> IModelTransformer The set of Elements that were deferred during a prior transformation pass.
_schemaExportDir Protected string IModelTransformer The directory where schemas will be exported, a random temporary directory
context Readonly IModelCloneContext IModelTransformer The IModelTransformContext for this IModelTransformer.
exporter Readonly IModelExporter IModelTransformer The IModelExporter that will export from the source iModel.
importer Readonly IModelImporter IModelTransformer The IModelImporter that will import into the target iModel.
provenanceDb Accessor ReadOnly IModelDb IModelTransformer Return the IModelDb where IModelTransformer will store its provenance.
sourceDb Readonly IModelDb IModelTransformer The normally read-only source iModel.
targetDb Readonly IModelDb IModelTransformer The read/write target iModel.
targetScopeElementId Readonly string IModelTransformer The Id of the Element in the target iModel that represents the source repository as a whole and scopes its ExternalSourceAspect instances.

Defined in

Last Updated: 29 November, 2022