insert MethodStatic

Insert a PhysicalPartition and a PhysicalModel that sub-models it.

insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string

throws IModelError if there is an insert problem.

Parameter Type Description
iModelDb IModelDb Insert into this iModel
parentSubjectId string The PhysicalPartition will be inserted as a child of this Subject element.
name string The name of the PhysicalPartition that the new PhysicalModel will sub-model.
isPlanProjection boolean Optional value (default is false) that indicates if the contents of this model are expected to be in an XY plane.

Returns - string

The Id of the newly inserted PhysicalPartition and PhysicalModel (same value).

Defined in

Last Updated: 29 November, 2022