insert MethodStatic
Insert a PhysicalPartition and a PhysicalModel that sub-models it.
insert(iModelDb: IModelDb, parentSubjectId: Id64String, name: string, isPlanProjection?: false | true): Id64String
throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentSubjectId | Id64String | The PhysicalPartition will be inserted as a child of this Subject element. |
name | string | The name of the PhysicalPartition that the new PhysicalModel will sub-model. |
isPlanProjection | false | true | Optional value (default is false) that indicates if the contents of this model are expected to be in an XY plane. |
Returns - Id64String
The Id of the newly inserted PhysicalPartition and PhysicalModel (same value).
Defined in
- core/backend/src/Model.ts Line 260
Last Updated: 13 June, 2024