NativeApp Class

The frontend of a native application

see Native Applications

Methods

Name Description
constructor(): NativeApp    
callNativeHost<T extends AsyncMethodsOf<NativeAppFunctions>>(methodName: T, ...args: Parameters<>): Promise<PromiseReturnType<>> Static    
checkInternetConnectivity(): Promise<InternetConnectivityStatus> Static determine whether the app currently has internet connectivity, if known  
closeStorage(storage: Storage, deleteStorage: boolean = false): Promise<void> Static Close a Storage and optionally delete it.  
deleteBriefcase(fileName: string): Promise<void> Static Delete an existing briefcase  
getBriefcaseFileName(props: BriefcaseProps): Promise<string> Static Get the full path filename for a briefcase within the briefcase cache  
getCachedBriefcases(iModelId?: string): Promise<LocalBriefcaseProps[]> Static Get a list of all briefcase files held in the local briefcase cache directory  
getStorageNames(): Promise<string[]> Static Get the list of existing Storages on the local disk.  
openStorage(name: string): Promise<Storage> Static Open a Storage.  
requestDownloadBriefcase(contextId: string, iModelId: string, downloadOptions: DownloadBriefcaseOptions, asOf: IModelVersion = ..., progress?: ProgressCallback): Promise<BriefcaseDownloader> Static    

Properties

Name Type Description
isValid Accessor StaticReadOnly boolean    
onInternetConnectivityChanged Static BeEvent<(status: InternetConnectivityStatus) => void> event called when internet connectivity changes, if known  

Defined in

Last Updated: 29 November, 2022