OidcBrowserClient Class
Deprecated Use BrowserAuthorizationClient instead
Beta
Utility to generate OIDC/OAuth tokens for Single Page Applications (running in the Browser)
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(_configuration: OidcFrontendClientConfiguration): OidcBrowserClient | Constructor | |
dispose(): void | Disposes the resources held by this client | |
getAccessToken(requestContext?: ClientRequestContext): Promise<AccessToken> | Returns a promise that resolves to the AccessToken of the currently authorized user. | |
initialize(requestContext: FrontendRequestContext): Promise<void> | Used to initialize the client - must be awaited before any other methods are called. | |
signIn(requestContext?: ClientRequestContext, successRedirectUrl?: string): Promise<void> | Start the sign-in process | |
signInSilent(requestContext: ClientRequestContext): Promise<User> Protected | Attempts a silent sign in with the authorization provider | |
signOut(requestContext?: ClientRequestContext): Promise<void> | Start the sign-out process |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyUserConfiguredHttpRequestOptions(requestOptions: RequestOptions, userDefinedRequestOptions?: HttpRequestOptions): void Protected | ImsAuthorizationClient | Configures request options based on user defined values in HttpRequestOptions |
delete(requestContext: AuthorizedClientRequestContext, relativeUrlPath: string, httpRequestOptions?: HttpRequestOptions): Promise<void> Protected | ImsAuthorizationClient | used by clients to send delete requests |
getUrl(requestContext: ClientRequestContext): Promise<string> | ImsAuthorizationClient | Gets the URL of the service. |
getUrlSearchKey(): string Protected | ImsAuthorizationClient | Gets name/key to query the service URLs from the URL Discovery Service ("Buddi") |
setupOptionDefaults(options: RequestOptions): Promise<void> Protected | ImsAuthorizationClient | Augments request options with defaults returned by the DefaultRequestOptionsProvider. |
Properties
Name | Type | Description | |
---|---|---|---|
_accessToken Protected | undefined | AccessToken | ||
hasExpired Accessor ReadOnly | boolean | Set to true if the user has signed in, but the token has expired and requires a refresh | |
hasSignedIn Accessor ReadOnly | boolean | Set to true if signed in - the accessToken may be active or may have expired and require a refresh | |
isAuthorized Accessor ReadOnly | boolean | Set to true if there's a current authorized user. | |
onUserStateChanged Readonly | BeEvent<(token: undefined | AccessToken) => void> | Event called when the user's sign-in state changes - this may be due to calls to signIn(), signOut(), if the token |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_url Protected | undefined | string | ImsAuthorizationClient | |
baseUrl Protected | undefined | string | ImsAuthorizationClient | Sets the default base URL to use with this client. |
searchKey StaticReadonly | string | ImsAuthorizationClient |
Defined in
Last Updated: 11 June, 2024