RenderSystem.Options Interface

Options passed to IModelApp.supplyRenderSystem to configure the RenderSystem on startup. Many of these options serve as "feature flags" used to enable newer, experimental features. As such they typically begin life tagged as "alpha" or "beta" and are subsequently deprecated when the feature is declared stable.

Properties

Name Type Description
antialiasSamples undefined | number Initial antialias setting  
devicePixelRatioOverride undefined | number If defined, this will be used as the device pixel ratio instead of the system's actual device pixel ratio.  
disabledExtensions undefined | WebGLExtensionName[] WebGL extensions to be explicitly disabled, regardless of whether or not the WebGL implementation supports them.  
displaySolarShadows undefined | boolean If true, display solar shadows when enabled by ViewFlags.shadows. Beta  
doIdleWork undefined | boolean To help prevent delays when a user interacts with a Viewport, the WebGL render system can precompile shader programs before any Viewport is opened.  
dpiAwareLOD undefined | boolean If true, ScreenViewports will take into account the DPI of the display when computing the level of detail for tile graphics and decorations.  
dpiAwareViewports undefined | boolean If true, ScreenViewports will respect the DPI of the display.  
filterMapDrapeTextures undefined | boolean ###TODO this appears to do nothing.  
filterMapTextures undefined | boolean ###TODO this appears to do nothing.  
logarithmicDepthBuffer undefined | boolean If the view frustum is sufficiently large, and the EXT_frag_depth WebGL extension is available, use a logarithmic depth buffer to improve depth buffer resolution.  
planProjections undefined | boolean If true, plan projection models will be rendered using PlanProjectionSettings defined by the DisplayStyle3dState.  
preserveShaderSourceCode undefined | boolean If true, preserve the shader source code as internal strings, useful for debugging purposes.  
useWebGL2 undefined | boolean If true will attempt to create a WebGL2 context, falling back to WebGL1 if WebGL2 is not supported.  

Defined in

Last Updated: 29 November, 2022