DisplayStyle3dState Class

A DisplayStyleState that can be applied to spatial views.

Extends

Methods

Name Description
constructor(props: DisplayStyleProps, iModel: IModelConnection, source?: DisplayStyle3dState): DisplayStyle3dState Construct a new DisplayStyleState from its JSON representation.  
setSunTime(time: number): void Set the solar light direction based on time value  

Inherited methods

Name Inherited from Description
attachRealityModel(props: ContextRealityModelProps): ContextRealityModelState DisplayStyleState Attach a ContextRealityModel to this display style.
changeBackgroundMapProps(props: BackgroundMapProps): void DisplayStyleState Modify a subset of the background map display settings.
changeMapLayerCredentials(index: number, isOverlay: boolean, userName?: string, password?: string): void DisplayStyleState  
changeMapSubLayerProps(props: MapSubLayerProps, subLayerId: SubLayerId, layerIndex: number, isOverlay: boolean): void DisplayStyleState  
changeRenderTimeline(timelineId: undefined | string): Promise<void> DisplayStyleState Change the Id of the RenderTimeline element that hosts the RenderSchedule.Script to be applied by this display style for
clone(iModel?: IModelConnection): DisplayStyle3dState DisplayStyleState Make an independent copy of this EntityState
detachRealityModelByNameAndUrl(name: string, url: string): boolean DisplayStyleState Detach the first ContextRealityModel that matches the specified name and url.
dropSubCategoryOverride(id: string): void DisplayStyleState Remove any SubCategoryOverride applied to a SubCategoryAppearance by this style.
equalState(other: DisplayStyleState): boolean DisplayStyleState Performs logical comparison against another display style.
equals(other: DisplayStyle3dState): boolean DisplayStyleState Return true if this EntityState is equal to another one.
forEachRealityModel(func: (model: ContextRealityModelState) => void): void DisplayStyleState Call a function for each reality model attached to this display style.
getOSMBuildingRealityModel(): undefined | ContextRealityModelState DisplayStyleState Get the ContextRealityModelState that displays the OpenStreetMap worldwide building layer, if enabled.
getSubCategoryOverride(id: string): undefined | SubCategoryOverride DisplayStyleState Obtain the overrides applied to a SubCategoryAppearance by this style.
hasAttachedRealityModel(name: string, url: string): boolean DisplayStyleState Return if a context reality model is attached.
is3d(): this is DisplayStyle3dState DisplayStyleState Returns true if this is a 3d display style.
load(): Promise<void> DisplayStyleState Ensures all of the data required by the display style is loaded.
overrideSubCategory(id: string, ovr: SubCategoryOverride): void DisplayStyleState Customize the way geometry belonging to a SubCategory is drawn by this display style.
setOSMBuildingDisplay(options: OsmBuildingDisplayOptions): boolean DisplayStyleState Set the display of the OpenStreetMap worldwide building layer in this display style by attaching or detaching the reality model displaying the buildings.
toJSON(): ElementProps DisplayStyleState Obtain this element's JSON representation.

Properties

Name Type Description
environment Accessor Environment The SkyBox and DisplayStyle3dState.GroundPlane settings for this style.  
lights Accessor LightSettings    
settings Accessor ReadOnly DisplayStyle3dSettings    
solarShadows Accessor SolarShadowSettings Settings controlling shadow display.  
sunDirection Accessor ReadOnly Readonly<Vector3d> The direction of the solar light.  

Inherited properties

Name Type Inherited from Description
backgroundColor Accessor ColorDef DisplayStyleState The background color for this DisplayStyle
backgroundMapSettings Accessor BackgroundMapSettings DisplayStyleState The settings controlling how a background map is displayed within a view.
classFullName Accessor StaticReadOnly string DisplayStyleState Get full BIS class name of this Entity in the form "SchemaName:ClassName".
classFullName Readonly string DisplayStyleState The full class name in the form "schema:class".
className Accessor ReadOnly string DisplayStyleState The name of the BIS class associated with this class.
code Readonly Code DisplayStyleState The Code for this element
contextRealityModelStates Accessor ReadOnly undefined DisplayStyleState ContextRealityModelStates attached to this display style.
federationGuid Readonly undefined | string DisplayStyleState A FederationGuid assigned to this element by some other federated database
hasSubCategoryOverride Accessor ReadOnly boolean DisplayStyleState Returns true if an SubCategoryOverrides are defined by this style.
id Readonly string DisplayStyleState The Id of this Entity.
iModel Readonly IModelConnection DisplayStyleState The iModel from which this Entity was loaded
jsonProperties Readonly { T } DisplayStyleState Optional json properties of this Entity.
model Readonly string DisplayStyleState The ModelId of the Model containing this element
monochromeColor Accessor ColorDef DisplayStyleState The color used to draw geometry in monochrome mode.
name Accessor ReadOnly string DisplayStyleState The name of this DisplayStyle
onOSMBuildingDisplayChanged Readonly BeEvent<(osmBuildingDisplayEnabled: boolean) => void> DisplayStyleState Event raised just after DisplayStyleState.setOSMBuildingDisplay changes the enabled state of the OSM buildings.
onScheduleScriptReferenceChanged Readonly BeEvent<(newScriptReference: undefined | ScriptReference) => void> DisplayStyleState Event raised just before the DisplayStyleState.scheduleScriptReference property is changed.
parent Readonly undefined | RelatedElement DisplayStyleState The parent Element of this, or undefined if no parent.
scheduleScript Accessor ReadOnly undefined | Script DisplayStyleState The RenderSchedule.Script that animates the contents of the view, if any.
scheduleScriptReference Accessor ReadOnly undefined | ScriptReference DisplayStyleState The RenderSchedule.Script that animates the contents of the view, if any, along with the Id of the element that hosts the script.
schemaName Accessor StaticReadOnly string DisplayStyleState The name of the BIS schema for this class.
userLabel Readonly undefined | string DisplayStyleState A user-assigned label for this element.
viewFlags Accessor ViewFlags DisplayStyleState Flags controlling various aspects of the display style.

Defined in

Last Updated: 29 November, 2022