finish Method

Finishes construction of the effect and, if successful, registers it with IModelApp.renderSystem.

finish(): void

throws Error if the shader fails to compile and link, or an effect with the same name has already been registered.

note After finish is called, no other properties or methods of the builder will have any effect.

Returns - void

Defined in

Last Updated: 29 November, 2022