CustomQueryInstanceNodesSpecification Interface

Creates nodes for instances which are returned by an ECSQL query.

Note: this specification is formerly known as SearchResultInstanceNodesSpecification.

see More details

Extends

Properties

Name Type Description
queries undefined | QuerySpecification[] Specifications of queries used to create the content.  
specType CustomQueryInstanceNodes Used for serializing to JSON.  

Inherited properties

Name Type Inherited from Description
doNotSort undefined | boolean ChildNodeSpecificationBase Set this flag to true to suppress default sorting of ECInstances returned by this specification.
groupByClass undefined | boolean DefaultGroupingPropertiesContainer Group instances by ECClass.
groupByLabel undefined | boolean DefaultGroupingPropertiesContainer Group instances by label.
hasChildren "Always" | "Never" | "Unknown" ChildNodeSpecificationBase This tells the rules engine that nodes produced using this
hideExpression undefined | string ChildNodeSpecificationBase An ECExpression which
hideIfNoChildren undefined | boolean ChildNodeSpecificationBase Hide nodes if they don't have children.
hideNodesInHierarchy undefined | boolean ChildNodeSpecificationBase Hide instance nodes provided by this specification and directly show nodes of its children.
nestedRules undefined | ChildNodeRule[] ChildNodeSpecificationBase Nested rule specifications.
priority undefined | number ChildNodeSpecificationBase Defines the order in which specifications are evaluated and executed.
relatedInstances undefined | RelatedInstanceSpecification[] ChildNodeSpecificationBase Specifications of related instances that can be used in nodes' creation.
suppressSimilarAncestorsCheck undefined | boolean ChildNodeSpecificationBase Suppress similar ancestor nodes' checking when creating nodes based on this specification.

Defined in

Last Updated: 29 November, 2022