propertyGridWithUnifiedSelection Function

Deprecated  Use usePropertyDataProviderWithUnifiedSelection hook

A HOC component that adds unified selection functionality to the supplied property grid component.

Note: it is required for the property grid to use IPresentationPropertyDataProvider

propertyGridWithUnifiedSelection<P extends PropertyGridProps>(PropertyGridComponent: ComponentType<P>): React.ComponentType<P & PropertyGridWithUnifiedSelectionProps>

Parameter Type Description
PropertyGridComponent ComponentType<P>  

Returns - React.ComponentType<P & PropertyGridWithUnifiedSelectionProps>

Defined in

Last Updated: 29 November, 2022