propertyGridWithUnifiedSelection Function
A HOC component that adds unified selection functionality to the supplied property grid component.
Note: it is required for the property grid to use IPresentationPropertyDataProvider
propertyGridWithUnifiedSelection<P extends PropertyGridProps>(PropertyGridComponent: React.ComponentType<P extends PropertyGridProps>): React.ComponentType<P extends PropertyGridProps & PropertyGridWithUnifiedSelectionProps>
Parameter | Type | Description |
---|---|---|
PropertyGridComponent | React.ComponentType<P extends PropertyGridProps> |
Returns - React.ComponentType<P extends PropertyGridProps & PropertyGridWithUnifiedSelectionProps>
Defined in
Last Updated: 13 June, 2024