Presentation Class

Static class used to statically set up Presentation library for the frontend. Basically what it does is:

Methods

Name Description
initialize(props?: PresentationManagerProps): Promise<void> Static Initializes Presentation library for the frontend.  
terminate(): void Static Terminates Presentation library frontend.  

Properties

Name Type Description
connectivity Accessor StaticReadOnly Provides information about current connection status.  
favoriteProperties Accessor StaticReadOnly FavoritePropertiesManager The singleton FavoritePropertiesManager  
i18n Accessor StaticReadOnly I18N The localization manager used by Presentation frontend.  
presentation Accessor StaticReadOnly PresentationManager The singleton PresentationManager  
selection Accessor StaticReadOnly SelectionManager The singleton SelectionManager  

Defined in

Last Updated: 29 November, 2022