EnumEditor Class

Beta  

EnumEditor React component that is a property editor with select input

Extends

Implements

Methods

Name Description
constructor(props: Readonly<PropertyEditorProps>): EnumEditor    
constructor(props: PropertyEditorProps, context?: any): EnumEditor    
getPropertyValue(): Promise<undefined | PropertyValue>    

Properties

Name Type Description
hasFocus Accessor ReadOnly boolean    
htmlElement Accessor ReadOnly | HTMLElement    

Defined in

Last Updated: 29 November, 2022