ThemedEnumPropertyEditor Class

Beta  

Enum Property Button Group Editor registered for the "enum" type name. It uses the EnumEditor React component.

Extends

Methods

Name Description
constructor(): ThemedEnumPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  

Properties

Name Type Description
containerHandlesBlur Accessor ReadOnly boolean    
containerHandlesEnter Accessor ReadOnly boolean    
containerHandlesEscape Accessor ReadOnly boolean    
containerHandlesTab Accessor ReadOnly boolean    
reactNode Accessor ReadOnly ReactNode    

Inherited properties

Name Type Inherited from Description
customDataController undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 29 November, 2022