FrontstageManager Class

Frontstage Manager class.

Methods

Name Description
constructor(): FrontstageManager    
addFrontstageProvider(frontstageProvider: FrontstageProvider): void Static Add a Frontstage via a FrontstageProvider.  
clearFrontstageDefs(): void Static Clears the Frontstage map.  
closeModalFrontstage(): void Static Closes the top-most modal Frontstage.  
closeNestedFrontstage(): Promise<void> Static Closes the top-most nested Frontstage.  
deactivateFrontstageDef(): Promise<void> Static Deactivates the active FrontstageDef.  
findFrontstageDef(id?: string): undefined | FrontstageDef Static Find a loaded Frontstage with a given id.  
findWidget(widgetId: string): undefined | WidgetDef Static Finds a widget with the given id in the active frontstage  
initialize(): void Static Initializes the FrontstageManager  
openModalFrontstage(modalFrontstage: ModalFrontstageInfo): void Static Opens a modal Frontstage.  
openNestedFrontstage(nestedFrontstage: FrontstageDef): Promise<void> Static Opens a nested Frontstage.  
setActiveFrontstage(frontstageId: string): Promise<void> Static Sets the active FrontstageDef.  
setActiveFrontstageDef(frontstageDef: undefined | FrontstageDef): Promise<void> Static Sets the active FrontstageDef.  
setActiveLayout(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup): Promise<void> Static Sets the active layout, content group and active content.  
setActiveNavigationAid(navigationAidId: string, iModelConnection: IModelConnection): void Static Sets the active Navigation Aid via its Id.  
setActiveTool(tool: Tool): void Static Sets the active tool  
setActiveToolId(toolId: string): void Static Sets the active tool id  
setWidgetState(widgetId: string, state: WidgetState): boolean Static Sets the state of the widget with the given id  
updateModalFrontstage(): void Static Updates the top-most modal Frontstage.  

Properties

Name Type Description
activeFrontstageDef Accessor StaticReadOnly undefined | FrontstageDef Gets the active FrontstageDef.  
activeFrontstageId Accessor StaticReadOnly string Gets the Id of the active FrontstageDef.  
activeModalFrontstage Accessor StaticReadOnly undefined | ModalFrontstageInfo Gets the top-most modal Frontstage.  
activeNestedFrontstage Accessor StaticReadOnly undefined | FrontstageDef Gets the top-most nested Frontstage.  
activeToolId Accessor StaticReadOnly string Gets the Id of the active tool.  
activeToolInformation Accessor StaticReadOnly undefined | ToolInformation Gets the active tool's ToolInformation  
isLoading Accessor StaticReadOnly boolean Returns true if Frontstage is loading its controls.  
modalFrontstageCount Accessor StaticReadOnly number Gets the number of modal Frontstages.  
nestedFrontstageCount Accessor StaticReadOnly number Gets the number of nested Frontstages.  
NineZoneManager Accessor StaticReadOnly NineZoneManager Get Nine-zone State Manager.  
onContentControlActivatedEvent StaticReadonly ContentControlActivatedEvent Get Content Control Activated event.  
onContentLayoutActivatedEvent StaticReadonly ContentLayoutActivatedEvent Get Content Layout Activated event.  
onFrontstageActivatedEvent StaticReadonly FrontstageActivatedEvent Get Frontstage Activated event.  
onFrontstageDeactivatedEvent StaticReadonly FrontstageDeactivatedEvent Get Frontstage Deactivated event.  
onFrontstageReadyEvent StaticReadonly FrontstageReadyEvent Get Frontstage Activated event.  
onModalFrontstageChangedEvent StaticReadonly ModalFrontstageChangedEvent Get Modal Frontstage Changed event.  
onModalFrontstageClosedEvent StaticReadonly ModalFrontstageClosedEvent Get Modal Frontstage Closed event.  
onNavigationAidActivatedEvent StaticReadonly NavigationAidActivatedEvent Get Navigation Aid Activated event.  
onToolActivatedEvent StaticReadonly ToolActivatedEvent Get Tool Activated event.  
onToolIconChangedEvent StaticReadonly ToolIconChangedEvent Get Tool Icon Changed event.  
onToolSettingsReloadEvent StaticReadonly UiEvent<void> Get ToolSetting Reload event.  
onWidgetStateChangedEvent StaticReadonly WidgetStateChangedEvent Get Widget State Changed event.  

Defined in

Last Updated: 29 November, 2022