ConditionalFieldProps Interface

Properties supported by ConditionalField component.

Extends

Methods

Name Description
boolFunc(props: StatusFieldProps): boolean Function to be called to return a boolean value.  

Inherited methods

Name Inherited from Description
onOpenWidget(widget: StatusBarFieldId): void StatusFieldProps Function called when the widget is opened or closed.

Properties

Name Type Description
defaultValue undefined | boolean Optional, default/initial boolean value that is saved in the components state.  

Inherited properties

Name Type Inherited from Description
className undefined | string StatusFieldProps Custom CSS class name
isInFooterMode boolean StatusFieldProps Indicates whether the StatusBar is in footer mode
openWidget StatusBarFieldId StatusFieldProps Field Id for open widgets
style undefined | CSSProperties StatusFieldProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022