withDragInteraction Function

Beta  

HOC to add open panel action via drag interaction.

withDragInteraction<P extends { T }, C>(Component: (props: P) => | ReactElement<any, string | JSXElementConstructor<any>> & C & (props: P) => Component<P, any, any> & C): (props: LibraryManagedAttributes<C, P & WithDragInteractionProps>) => Element

Parameter Type Description
Component (props: P) => | ReactElement<any, string | JSXElementConstructor<any>> & C & (props: P) => Component<P, any, any> & C  

Returns - (props: LibraryManagedAttributes<C, P & WithDragInteractionProps>) => Element

Defined in

Last Updated: 29 November, 2022