collectCurvePrimitivesGo Method
Return an array containing only the curve primitives.
- This DEFAULT simply pushes
this
to the collectorArray. - CurvePrimitiveWithDistanceIndex optionally collects its members.
collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], _smallestPossiblePrimitives: boolean): void
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | array to receive primitives (pushed -- the array is not cleared) |
_smallestPossiblePrimitives | boolean |
Returns - void
Defined in
Last Updated: 13 June, 2024