Texture Class

Defines a rendering texture that is associated with a Material and applied to surface geometry.

Extends

Implements

Methods

Name Description
create(iModelDb: IModelDb, definitionModelId: Id64String, name: string, format: ImageSourceFormat, data: string, width: number, height: number, description: string, flags: TextureFlags): Texture Static Create a Texture with given parameters.  
createCode(iModel: IModelDb, scopeModelId: CodeScopeProps, name: string): Code Static Create a Code for a Texture given a name that is meant to be unique within the scope of the specified DefinitionModel.  
insert(iModelDb: IModelDb, definitionModelId: Id64String, name: string, format: ImageSourceFormat, data: string, width: number, height: number, description: string, flags: TextureFlags): Id64String Static Insert a new Texture into a model.  

Inherited methods

Name Inherited from Description
buildConcurrencyControlRequest(opcode: DbOpcode): void Element Add a request for locks, code reservations, and anything else that would be needed to carry out the specified operation.
delete(): void Element Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = false): void Entity Call a function for each property of this Entity.
Element Get the class metadata for this element.
getDisplayLabel(): string Element Get a display label for this Element.
getJsonProperty(nameSpace: string): any Element Get a JSON property of this element, by namespace
getToolTipMessage(): string[] Element Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Element Get a set of JSON user properties by namespace
insert(): string Element Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void Element Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Element  
setUserProperties(nameSpace: string, value: any): void Element Change a set of user JSON properties of this Element by namespace.
update(): void Element Update this Element in the iModel.
onAllInputsHandled(_id: Id64String, _iModel: IModelDb): void ProtectedStatic Element  
onBeforeOutputsHandled(_id: Id64String, _iModel: IModelDb): void ProtectedStatic Element  
onDelete(props: ElementProps, iModel: IModelDb): void ProtectedStatic Element Called before an Element is deleted.
onDeleted(_props: ElementProps, _iModel: IModelDb): void ProtectedStatic Element Called after an Element was deleted.
onInsert(props: ElementProps, iModel: IModelDb): void ProtectedStatic Element Called before a new Element is inserted.
onInserted(props: ElementProps, iModel: IModelDb): void ProtectedStatic Element Called after a new Element was inserted.
onUpdate(props: ElementProps, iModel: IModelDb): void ProtectedStatic Element Called before an Element is updated.
onUpdated(props: ElementProps, iModel: IModelDb): void ProtectedStatic Element Called after an Element was updated.
populateRequest(req: ConcurrencyControl.Request, props: ElementProps, _iModel: IModelDb, opcode: DbOpcode, original: ElementProps | undefined): void Static Element Disclose the codes and locks needed to perform the specified operation on this element

Properties

Name Type Description
data string    
description undefined | string    
flags TextureFlags    
format ImageSourceFormat    
height number    
width number    

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string Entity Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string Entity Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string Entity The name of the BIS class associated with this class.
code Code Element The Code for this element
federationGuid undefined | GuidString Element A FederationGuid assigned to this element by some other federated database
id Id64String Entity The Id of this Entity.
iModel IModelDb Entity The IModelDb that contains this Entity
isPrivate boolean DefinitionElement If true, don't show this DefinitionElement in user interface lists.
jsonProperties [key: string]: any Element Optional json properties of this element.
model Id64String Element The ModelId of the Model containing this element
parent undefined | RelatedElement Element The parent element, if present, of this element.
schema Static undefined Entity The Schema that defines this class.
schemaName Accessor ReadOnly string Entity The name of the BIS Schema that defines this class
userLabel undefined | string Element A user-assigned label for this element.

Defined in

Last Updated: 05 June, 2020