ConcurrencyControl.Request Class
A request for locks and/or code reservations.
Methods
Name | Description | |
---|---|---|
addCodes(codes: CodeProps[]): this | ||
addLocks(locks: ConcurrencyControl.LockProps[]): this | ||
clear(): void | ||
getLockByKey(type: LockType, objectId: string): ConcurrencyControl.LockProps | undefined | ||
removeCodes(filter: (c: CodeProps) => boolean, context: any): void | ||
removeLocks(filter: (l: ConcurrencyControl.LockProps) => boolean, context: any): void | ||
getElementLock(objectId: Id64String, level: LockLevel): ConcurrencyControl.LockProps Static | ||
getHubCodeSpecsLock(concurrencyControl: ConcurrencyControl): Lock Static | ||
getHubSchemaLock(concurrencyControl: ConcurrencyControl): Lock Static | ||
getModelLock(objectId: Id64String, level: LockLevel): ConcurrencyControl.LockProps Static | ||
toHubCode(concurrencyControl: ConcurrencyControl, code: CodeProps): HubCode Static | ||
toHubCodes(concurrencyControl: ConcurrencyControl, codes: CodeProps[]): HubCode[] Static | ||
toHubLock(concurrencyControl: ConcurrencyControl, reqLock: ConcurrencyControl.LockProps): Lock Static | ||
toHubLocks(concurrencyControl: ConcurrencyControl, locks: ConcurrencyControl.LockProps[]): Lock[] Static |
Properties
Name | Type | Description | |
---|---|---|---|
codes Accessor ReadOnly | CodeProps[] | ||
codeSpecsLock Accessor StaticReadOnly | ConcurrencyControl.LockProps | ||
dbLock Accessor StaticReadOnly | ConcurrencyControl.LockProps | ||
isEmpty Accessor ReadOnly | boolean | ||
locks Accessor ReadOnly | ConcurrencyControl.LockProps[] | ||
schemaLock Accessor StaticReadOnly | ConcurrencyControl.LockProps |
Defined in
Last Updated: 13 June, 2024