areCodesAvailable Method

Check to see that this briefcase could reserve (or has already reserved) all of the specified Codes.

areCodesAvailable(requestContext: AuthorizedClientRequestContext, req?: ConcurrencyControl.Request): Promise<boolean>

Parameter Type Description
requestContext AuthorizedClientRequestContext The client request context
req ConcurrencyControl.Request the codes to be checked for their available status. If not specified then all pending requests for codes are queried.

Returns - true if all codes are available or false if any is not.

Defined in

Last Updated: 05 June, 2020