tryGetSubModel Method

Get the sub-model of the specified Element. See IModelDb.Elements.queryElementIdByCode for more on how to find an element by Code.

tryGetSubModel<T extends Model>(modeledElementId: Id64String | GuidString | Code): T extends Model | undefined

see IModelDb.Models.getSubModel

Parameter Type Description
modeledElementId Id64String | GuidString | Code Identifies the modeled element.

Returns - The sub-model or undefined if the specified element does not have a sub-model.

Defined in

Last Updated: 05 June, 2020