queryRowCount Method
Compute number of rows that would be returned by the ECSQL.
See also:
queryRowCount(ecsql: string, bindings?: any[] | object): Promise<number>
throws IModelError If the statement is invalid
Parameter | Type | Description |
---|---|---|
ecsql | string | The ECSQL statement to execute |
bindings | any[] | object | The values to bind to the parameters (if the ECSQL has any). Pass an array of values if the parameters are positional. Pass an object of the values keyed on the parameter name for named parameters. The values in either the array or object must match the respective types of the parameters. See "iModel.js Types used in ECSQL Parameter Bindings" for details. |
Returns - Promise<number>
Return row count.
Defined in
- core/backend/src/IModelDb.ts Line 642
Last Updated: 13 June, 2024