insert MethodStatic
Insert a DefinitionPartition and a DefinitionModel that sub-models it.
insert(iModelDb: IModelDb, parentSubjectId: Id64String, name: string): Id64String
throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentSubjectId | Id64String | The DefinitionPartition will be inserted as a child of this Subject element. |
name | string | The name of the DefinitionPartition that the new DefinitionModel will sub-model. |
Returns - Id64String
The Id of the newly inserted DefinitionModel.
Defined in
- core/backend/src/Model.ts Line 405
Last Updated: 13 June, 2024