PhysicalModel Class
A container for persisting physical elements that model physical space.
see PhysicalPartition
Extends
Implements
Methods
Name |
Description |
|
insert(iModelDb: IModelDb, parentSubjectId: Id64String, name: string, isPlanProjection?: false | true): Id64String Static |
Insert a PhysicalPartition and a PhysicalModel that sub-models it. |
|
Inherited methods
Name |
Inherited from |
Description |
buildConcurrencyControlRequest(opcode: DbOpcode): void |
Model |
Add a request for the locks that would be needed to carry out the specified operation. |
delete(): void |
Model |
Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = false): void |
Entity |
Call a function for each property of this Entity. |
getJsonProperty(name: string): any |
Model |
|
getUserProperties(namespace: string): any |
Model |
Get a set of JSON user properties by namespace |
insert(): string |
Model |
Insert this Model in the iModel |
queryExtents(): AxisAlignedBox3d |
GeometricModel |
Query for the union of the extents of the elements contained by this model. |
removeUserProperties(nameSpace: string): void |
Model |
Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void |
Model |
|
setUserProperties(nameSpace: string, value: any): void |
Model |
Change a set of user JSON properties of this Element by namespace. |
update(): void |
Model |
Update this Model in the iModel. |
onDelete(props: ModelProps, iModel: IModelDb): void ProtectedStatic |
Model |
Called before a model is deleted. |
onDeleted(_props: ModelProps, _iModel: IModelDb): void ProtectedStatic |
Model |
Called after a model is deleted. |
onInsert(props: ModelProps, iModel: IModelDb): void ProtectedStatic |
Model |
Called before a new model is inserted. |
onInserted(id: string, iModel: IModelDb): void ProtectedStatic |
Model |
Called after a new model is inserted. |
onUpdate(props: ModelProps, iModel: IModelDb): void ProtectedStatic |
Model |
Called before a model is updated. |
onUpdated(props: ModelProps, iModel: IModelDb): void ProtectedStatic |
Model |
Called after a model is updated. |
populateRequest(req: ConcurrencyControl.Request, props: ModelProps, iModel: IModelDb, opcode: DbOpcode): void Static |
Model |
Disclose the codes and locks needed to perform the specified operation on this model |
Inherited properties
Defined in
Last Updated:
13 June, 2024