ViewFlags Class

Flags for controlling how graphics appear within a View.

Methods

Name Description
clone(out?: ViewFlags): ViewFlags    
equals(other: ViewFlags): boolean    
toJSON(): ViewFlagProps    
createFrom(other?: ViewFlags, out?: ViewFlags): ViewFlags Static    
fromJSON(json?: ViewFlagProps): ViewFlags Static    

Properties

Name Type Description
acsTriad boolean Shows or hides the ACS triad.  
ambientOcclusion boolean Controls whether ambient occlusion is used.  
backgroundMap boolean Display background map  
cameraLights boolean Controls whether camera (ambient, portrait, flashbulb) lights are used.  
clipVolume boolean Controls whether the clip volume is applied.  
constructions boolean Shows or hides construction class geometry.  
dimensions boolean Shows or hides dimensions.  
fill boolean Controls whether the fills on filled elements are displayed.  
forceSurfaceDiscard boolean Controls whether surface discard is always applied regardless of other ViewFlags.  
grid boolean Shows or hides the grid.  
hiddenEdges boolean Shows or hides hidden edges in the shaded render mode.  
hLineMaterialColors boolean Use material colors for hidden lines  
lighting Accessor boolean Controls whether or not lighting is applied.  
materials boolean Controls whether materials are used (e.g.  
monochrome boolean Draw all graphics in a single color  
patterns boolean Shows or hides pattern geometry.  
renderMode RenderMode The RenderMode of the view.  
shadows boolean Shows or hides shadows.  
solarLight boolean Controls whether sunlight used  
sourceLights boolean Controls whether the source lights in spatial models are used  
styles boolean Controls whether custom line styles are used (e.g.  
textures boolean Controls whether to display texture maps for material assignments.  
transparency boolean Controls whether element transparency is used (e.g.  
visibleEdges boolean Shows or hides visible edges in the shaded render mode.  
weights boolean Controls whether non-zero line weights are used or display using weight 0.  

Defined in

Last Updated: 05 June, 2020