ElementState Class

The "state" of an Element as represented in a web browser.

Extends

Extended by

Implements

Methods

Name Description
constructor(props: ElementProps, iModel: IModelConnection): ElementState    

Inherited methods

Name Inherited from Description
clone(iModel?: IModelConnection): this EntityState Make an independent copy of this EntityState
equals(other: this): boolean EntityState Return true if this EntityState is equal to another one.

Properties

Name Type Description
code Code The Code for this element  
federationGuid undefined | GuidString A FederationGuid assigned to this element by some other federated database  
model Id64String The ModelId of the Model containing this element  
parent undefined | RelatedElement The parent Element of this, or undefined if no parent.  
userLabel undefined | string A user-assigned label for this element.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor StaticReadOnly string EntityState Get full BIS class name of this Entity in the form "SchemaName:ClassName".
classFullName string EntityState The full class name in the form "schema:class".
className Accessor ReadOnly string EntityState The name of the BIS class associated with this class.
id Id64String EntityState The Id of this Entity.
iModel IModelConnection EntityState The iModel from which this Entity was loaded
jsonProperties [key: string]: any EntityState Optional json properties of this Entity.
schemaName Accessor StaticReadOnly string EntityState The name of the BIS schema for this class.

Defined in

Last Updated: 23 April, 2020