SectionDrawingModelState Class
Represents the front-end state of a SectionDrawingModel.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: GeometricModel2dProps, iModel: IModelConnection, state?: GeometricModel2dState): SectionDrawingModelState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): this | EntityState | Make an independent copy of this EntityState |
equals(other: this): boolean | EntityState | Return true if this EntityState is equal to another one. |
toJSON(): GeometricModel2dProps | GeometricModel2dState |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
asGeometricModel3d Accessor ReadOnly | GeometricModel3dState | undefined | ModelState | Attempts to cast this model to a 3d geometric model. |
asSpatialModel Accessor ReadOnly | SpatialModelState | undefined | ModelState | Attempts to cast this model to a spatial model. |
classFullName Accessor StaticReadOnly | string | EntityState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName | string | EntityState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | EntityState | The name of the BIS class associated with this class. |
id | Id64String | EntityState | The Id of this Entity. |
iModel | IModelConnection | EntityState | The iModel from which this Entity was loaded |
is2d Accessor ReadOnly | boolean | GeometricModelState | Returns true if this is a 2d model (a GeometricModel2dState). |
isPrivate | boolean | ModelState | |
isTemplate | boolean | ModelState | |
jsonProperties | [key: string]: any | EntityState | Optional json properties of this Entity. |
modeledElement | RelatedElement | ModelState | |
name | string | ModelState | |
parentModel | Id64String | ModelState | |
schemaName Accessor StaticReadOnly | string | EntityState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/ModelState.ts Line 263
Last Updated: 13 June, 2024