EngineeringLengthDescription Class
Beta
Engineering Length Property Description
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(name?: string, displayLabel?: string, iconSpec?: string): EngineeringLengthDescription |
Inherited methods
Name | Inherited from | Description |
---|---|---|
format(numberValue: number): string | BaseQuantityDescription | |
parse(userInput: string): ParseResults | BaseQuantityDescription |
Properties
Name | Type | Description | |
---|---|---|---|
parseError Accessor ReadOnly | string | ||
quantityType Accessor ReadOnly | QuantityType |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
displayLabel | string | BaseQuantityDescription | |
editor | PropertyEditorInfo | BaseQuantityDescription | |
formatterSpec Accessor ReadOnly | FormatterSpec | undefined | BaseQuantityDescription | |
name | string | BaseQuantityDescription | |
parserSpec Accessor ReadOnly | ParserSpec | undefined | BaseQuantityDescription | |
typename | string | BaseQuantityDescription |
Defined in
Last Updated: 13 June, 2024