ToolSettings Class
Settings that control the behavior of built-in tools. Applications may modify these values.
Properties
Name | Type | Description | |
---|---|---|---|
animationTime Accessor Static | BeDuration | Deprecated | |
doubleClickTimeout Static | BeDuration | Two clicks must be within this period to be a double click. | |
doubleClickToleranceInches Static | number | Number of screen inches of movement allowed between clicks to still qualify as a double-click. | |
doubleTapTimeout Static | BeDuration | Two tap must be within this period to be a double tap. | |
preserveWorldUp Static | boolean | If true, view rotation tool keeps the up vector (worldZ) aligned with screenY. | |
scrollSpeed Static | number | the speed to scroll for the "scroll view" tool (distance per second). | |
startDragDelay Static | BeDuration | Delay with the mouse down before a drag operation begins. | |
startDragDistanceInches Static | number | Distance in screen inches the cursor must move before a drag operation begins. | |
touchMoveDelay Static | BeDuration | Delay with a touch on the surface before a move operation begins. | |
touchMoveDistanceInches Static | number | Distance in screen inches a touch point must move before being considered motion. | |
touchZoomChangeThresholdInches Static | number | Distance in screen inches touch points must move apart to be considered a change in zoom scale. | |
viewToolPickRadiusInches Static | number | Radius in screen inches to search for elements that anchor viewing operations. | |
walkCameraAngle Static | Angle | Camera angle enforced for walk tool. | |
walkEnforceZUp Static | boolean | Whether the walk tool enforces worldZ be aligned with screenY | |
walkRequestPointerLock Static | boolean | Whether the walk tool requests pointer lock to hide the cursor for mouse look | |
walkVelocity Static | number | Speed, in meters per second, for the walk tool. | |
wheelLineFactor Static | number | Scale factor applied for wheel events with "per-line" modifier. | |
wheelPageFactor Static | number | Scale factor applied for wheel events with "per-page" modifier. | |
wheelZoomBumpDistance Static | number | When the zoom-with-wheel tool (with camera enabled) gets closer than this distance to an obstacle, it "bumps" through. | |
wheelZoomRatio Static | number | Scale factor for zooming with mouse wheel. | |
zoomSpeed Static | number | the speed to zoom for the "zoom view" tool. |
Object Literals
Name | Description |
---|---|
viewingInertia Static | Parameters for viewing operations with inertia (i.e. they continue briefly if used with a throwing action) |
Defined in
Last Updated: 13 June, 2024