ViewChangeOptions Interface
Options that control how operations that change a viewport behave.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
animateFrustumChange | undefined | false | true | Whether the change should be animated or not. | |
marginPercent | undefined | MarginPercent | The percentage of the view to leave blank around the edges. | |
noSaveInUndo | undefined | false | true | Whether to save the result of this change into the view undo stack. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
animationTime | undefined | number | ViewAnimationOptions | Amount of time for animation, in milliseconds. |
cancelOnAbort | undefined | false | true | ViewAnimationOptions | if animation is aborted, don't move to end, leave at current point instead. |
easingFunction | undefined | EasingFunction | ViewAnimationOptions | easing function for animation. |
Defined in
- core/frontend/src/Viewport.ts Line 231
Last Updated: 13 June, 2024