Change Log - presentation-common
1.14.1
Wed Apr 22 2020
Updates
- Documentation
1.14.0
Tue Mar 31 2020
Version update only
1.13.0
Wed Mar 04 2020
Version update only
1.12.0
Wed Feb 12 2020
Updates
- Fix broken links
- Make
KeySetJSON
and related types public - Add multi-step relationship path's support in presentation rules.
- Implement multi-step relationship paths support for find similar ruleset
1.11.0
Wed Jan 22 2020
Updates
- Added LabelDefinition and changed Node label property type to LabelDefinition
- Include missing assets directory into package
- Rename
ContentInstancesOfSpecificClassesSpecification.arePolymorphic
tohandleInstancesPolymorphically
to remove ambiguity - Upgrade to TypeScript 3.7.2.
1.10.0
Tue Jan 07 2020
Version update only
1.9.0
Tue Dec 10 2019
Updates
- Fix double quotes not being properly escaped when creating 'find similar' ruleset.
- Add support for multi-ECInstance nodes
- Add a way to group same-label ECInstance nodes at post-processing stage
- Add
NestedContentField.getFieldByName
- Update sinon version.
1.8.0
Fri Nov 22 2019
Updates
- Add property overrides' rule
- Deprecate
PropertiesDisplaySpecification
in favor ofPropertyOverrides
- Deprecate
PropertyEditorsSpecification
in favor ofPropertyOverrides
1.7.0
Fri Nov 01 2019
Version update only
1.6.0
Wed Oct 09 2019
Version update only
1.5.0
Mon Sep 30 2019
Updates
- Add
PresentationStatus.Canceled
member - Add ability to force-load all hierarchy with the given imodel and ruleset
- Added autoExpand property to RelatedPropertiesSpecification and NestedContentField
- Add module descriptions
- Added Ruleset and Ruleset variables to request options to support stateless presentation backend
- Store navigation property classes separate from related property paths
- upgrade to TypeScript 3.6.2
1.4.0
Tue Sep 10 2019
Updates
- Escape double quotes when creating intance filter for 'find similar' ruleset
- Add NodeArtifacts presentation rule
- Add
hideExpression
attribute to node specifications
1.3.0
Tue Aug 13 2019
Updates
- Add special handling for double values when creating 'similar instances' presentantation ruleset
- Add special handling for point values when creating 'similar instances' presentation ruleset
- Add special handling for DateTime values when creating 'similar instances' presentation ruleset
1.2.0
Wed Jul 24 2019
Version update only
1.1.0
Mon Jul 01 2019
Updates
- Reorganize docs script output
- Add functions
KeySet.forEach
andKeySet.forEachBatch
- Downgrade json-schema-faker dependency to version
0.5.0-rc16
asrc17
causes some tests to crash - Add "String" value specification for
InstanceLabelOverride
rule - Update to TypeScript 3.5
1.0.0
Mon Jun 03 2019
Updates
- RPC system now accepts only basic values (primitives, "interface" objects, and binary).
- Add optional predicate parameter to
KeySet.add
to filter added keys - Add a new presentation rule
ExtendedDataRule
for injecting custom data into presentation objects. - Refactor InstanceLabelOverride rule for more flexibility
- Added handling for timeouted backend responses with request repeating
- Add release tags
- Cleanup API
- Refactor RPC interface to use pure JSON objects
- Fix content descriptor deserialization
0.191.0
Mon May 13 2019
Updates
- Adds parameter for api-extractor to validate missing release tags
- Fix broken links
- Put sourcemap in npm package.
- Fix creating a KeySet from EntityProps which have a
type
property - Fix marshaling class instances through RPC by removing use of Readonly
- Add APIs to retrieve instance labels
- Changed
PresentationRpcInterface.computeSelection
to takeId64String[]
instead ofEntityProps[]
- Allow sending content descriptor overrides instead of descriptor when requesting content. This allows to competely avoid a descriptor request when content customization requirements are the same for all kinds of content
- Upgrade TypeDoc dependency to 0.14.2
0.190.0
Thu Mar 14 2019
Updates
- Documentation fixes
- Fix test scripts for unix systems
0.189.0
Wed Mar 06 2019
Updates
- Changes package.json to include api-extractor and adds api-extractor.json
- Added RpcResponse and PresentationRpcResponse interfaces and changed PresentationRpcInterface to return PresentationRpcResponses instead of raw values.
- Use new buildIModelJsBuild script
- Remove unneeded typedoc plugin dependency
- Create RulesetFactory API for creating presentation rulesets targeted towards specific cases, like 'find similar', etc.
- Save BUILD_SEMVER to globally accessible map
- Change
RulesetsFactory.createSimilarInstancesRuleset
return type from aRuleset
to{ ruleset: Ruleset, description: string }
- Fix RPC requests handler to re-request data if frontend got out-of-sync while syncing with the backed.
- Add selection scopes -related RPC handlers
- RPC Interface changes to optimize getting first page of nodes/content
- Expose node key type guards through index
- upgrade to TypeScript 3.2.2
0.188.0
Wed Jan 16 2019
Version update only
0.187.0
Tue Jan 15 2019
Version update only
0.186.0
Mon Jan 14 2019
Version update only
0.185.0
Fri Jan 11 2019
Updates
- Introduce
groupedInstancesCount
property for grouping node keys - Add
KeySet.instanceKeysCount
andKeySet.nodeKeysCount
which are faster versions ofKeySet.instanceKeys.size
andKeySet.nodeKeys.size
- Add helper functions to identify type of node key
- Add
getInstancesCount
function to calculate total number of instances included in aKeySet
0.184.0
Thu Jan 10 2019
Version update only
0.183.0
Mon Jan 07 2019
Version update only
0.182.0
Mon Jan 07 2019
Version update only
0.181.0
Fri Jan 04 2019
Version update only
0.180.0
Wed Jan 02 2019
Version update only
0.179.0
Wed Dec 19 2018
Updates
- Invert
isSelectable
property toisSelectionDisabled
so in the most common case (selectable = true) we don't have to send the value
0.178.0
Thu Dec 13 2018
Version update only
0.177.0
Wed Dec 12 2018
Version update only
0.176.0
Mon Dec 10 2018
Updates
- React to signature change for RpcInterface.forward
0.175.0
Mon Dec 10 2018
Version update only
0.174.0
Mon Dec 10 2018
Updates
- Remove unused dependencies, add
build:watch
script
0.173.0
Thu Dec 06 2018
Version update only
0.172.0
Tue Dec 04 2018
Updates
- Changed index file name to match package name, eliminate subdirectory index files, decrease usage of default exports, change imports to use other packages' index file.
0.171.0
Mon Dec 03 2018
Version update only
0.170.0
Mon Nov 26 2018
Version update only
0.169.0
Tue Nov 20 2018
Version update only
0.168.0
Sat Nov 17 2018
Version update only
0.167.0
Fri Nov 16 2018
Version update only
0.166.0
Mon Nov 12 2018
Version update only
0.165.0
Mon Nov 12 2018
Updates
- Add KeySet.hasAll and KeySet.hasAny to check set contents
- Add KeySet.guid to check if keys have changed
0.164.0
Thu Nov 08 2018
Updates
- Updated to TypeScript 3.1
0.163.0
Wed Oct 31 2018
Version update only
0.162.0
Wed Oct 24 2018
Updates
- Fix value deserialization when values were not set (null vs undefined)
- Hide internal types from declarations and docs
0.161.0
Fri Oct 19 2018
Version update only
0.160.0
Wed Oct 17 2018
Version update only
0.159.0
Tue Oct 16 2018
Version update only
0.158.0
Mon Oct 15 2018
Version update only
0.157.0
Sun Oct 14 2018
Updates
- Fixing scripts for linux
0.156.0
Fri Oct 12 2018
Updates
- Initial release
Last Updated: 13 June, 2024