DisplayValuesArray Interface

An array of display values

Extends

Inherited methods

Name Inherited from Description
Symbol.iterator(): IterableIterator<DisplayValue> Array.Symbol Iterator
Symbol.unscopables(): object Array.Symbol Returns an object whose properties have the value 'true'
concat(...items: ConcatArray<DisplayValue>[]): DisplayValue[] Array<DisplayValue> Combines two or more arrays.
concat(...items: T | ConcatArray<T>[]): DisplayValue[] Array<DisplayValue> Combines two or more arrays.
copyWithin(target: number, start: number, end?: number): this Array<DisplayValue> Returns the this object after copying a section of the array identified by start and end
entries(): IterableIterator<[number, DisplayValue]> Array<DisplayValue> Returns an iterable of key, value pairs for every entry in the array
every(callbackfn: (value: DisplayValue, index: number, array: DisplayValue[]) => unknown, thisArg?: any): boolean Array<DisplayValue> Determines whether all the members of an array satisfy the specified test.
fill(value: DisplayValue, start?: number, end?: number): this Array<DisplayValue> Returns the this object after filling the section identified by start and end with value
filter<S extends DisplayValue>(callbackfn: (value: DisplayValue, index: number, array: DisplayValue[]) => value, thisArg?: any): S extends DisplayValue[] Array<DisplayValue> Returns the elements of an array that meet the condition specified in a callback function.
filter(callbackfn: (value: DisplayValue, index: number, array: DisplayValue[]) => unknown, thisArg?: any): DisplayValue[] Array<DisplayValue> Returns the elements of an array that meet the condition specified in a callback function.
find<S extends DisplayValue>(predicate: (this: void, value: DisplayValue, index: number, obj: DisplayValue[]) => value, thisArg?: any): S extends DisplayValue | undefined Array<DisplayValue> Returns the value of the first element in the array where predicate is true, and undefined
find(predicate: (value: DisplayValue, index: number, obj: DisplayValue[]) => unknown, thisArg?: any): DisplayValue | undefined Array<DisplayValue>  
findIndex(predicate: (value: DisplayValue, index: number, obj: DisplayValue[]) => unknown, thisArg?: any): number Array<DisplayValue> Returns the index of the first element in the array where predicate is true, and -1
forEach(callbackfn: (value: DisplayValue, index: number, array: DisplayValue[]) => void, thisArg?: any): void Array<DisplayValue> Performs the specified action for each element in an array.
includes(searchElement: DisplayValue, fromIndex?: number): boolean Array<DisplayValue> Determines whether an array includes a certain element, returning true or false as appropriate.
indexOf(searchElement: DisplayValue, fromIndex?: number): number Array<DisplayValue> Returns the index of the first occurrence of a value in an array.
join(separator?: string): string Array<DisplayValue> Adds all the elements of an array separated by the specified separator string.
keys(): IterableIterator<number> Array<DisplayValue> Returns an iterable of keys in the array
lastIndexOf(searchElement: DisplayValue, fromIndex?: number): number Array<DisplayValue> Returns the index of the last occurrence of a specified value in an array.
map<U>(callbackfn: (value: DisplayValue, index: number, array: DisplayValue[]) => U, thisArg?: any): U[] Array<DisplayValue> Calls a defined callback function on each element of an array, and returns an array that contains the results.
pop(): DisplayValue | undefined Array<DisplayValue> Removes the last element from an array and returns it.
push(...items: DisplayValue[]): number Array<DisplayValue> Appends new elements to an array, and returns the new length of the array.
reduce(callbackfn: (previousValue: DisplayValue, currentValue: DisplayValue, currentIndex: number, array: DisplayValue[]) => DisplayValue): DisplayValue Array<DisplayValue> Calls the specified callback function for all the elements in an array.
reduce(callbackfn: (previousValue: DisplayValue, currentValue: DisplayValue, currentIndex: number, array: DisplayValue[]) => DisplayValue, initialValue: DisplayValue): DisplayValue Array<DisplayValue>  
reduce<U>(callbackfn: (previousValue: U, currentValue: DisplayValue, currentIndex: number, array: DisplayValue[]) => U, initialValue: U): U Array<DisplayValue> Calls the specified callback function for all the elements in an array.
reduceRight(callbackfn: (previousValue: DisplayValue, currentValue: DisplayValue, currentIndex: number, array: DisplayValue[]) => DisplayValue): DisplayValue Array<DisplayValue> Calls the specified callback function for all the elements in an array, in descending order.
reduceRight(callbackfn: (previousValue: DisplayValue, currentValue: DisplayValue, currentIndex: number, array: DisplayValue[]) => DisplayValue, initialValue: DisplayValue): DisplayValue Array<DisplayValue>  
reduceRight<U>(callbackfn: (previousValue: U, currentValue: DisplayValue, currentIndex: number, array: DisplayValue[]) => U, initialValue: U): U Array<DisplayValue> Calls the specified callback function for all the elements in an array, in descending order.
reverse(): DisplayValue[] Array<DisplayValue> Reverses the elements in an Array.
shift(): DisplayValue | undefined Array<DisplayValue> Removes the first element from an array and returns it.
slice(start?: number, end?: number): DisplayValue[] Array<DisplayValue> Returns a section of an array.
some(callbackfn: (value: DisplayValue, index: number, array: DisplayValue[]) => unknown, thisArg?: any): boolean Array<DisplayValue> Determines whether the specified callback function returns true for any element of an array.
sort(compareFn?: (a: DisplayValue, b: DisplayValue) => number): this Array<DisplayValue> Sorts an array.
splice(start: number, deleteCount?: number): DisplayValue[] Array<DisplayValue> Removes elements from an array and, if necessary, inserts new elements in their place, returning the deleted elements.
splice(start: number, deleteCount: number, ...items: DisplayValue[]): DisplayValue[] Array<DisplayValue> Removes elements from an array and, if necessary, inserts new elements in their place, returning the deleted elements.
toLocaleString(): string Array<DisplayValue> Returns a string representation of an array.
toString(): string Array<DisplayValue> Returns a string representation of an array.
unshift(...items: DisplayValue[]): number Array<DisplayValue> Inserts new elements at the start of an array.
values(): IterableIterator<DisplayValue> Array<DisplayValue> Returns an iterable of values in the array

Properties

Name Type Description
Array ArrayConstructor    

Inherited properties

Name Type Inherited from Description
length number Array<DisplayValue> Gets or sets the length of the array.

Defined in

Last Updated: 05 June, 2020