ValuesArray Interface

An array of raw values

Extends

Inherited methods

Name Inherited from Description
Symbol.iterator(): IterableIterator<Value> Array.Symbol Iterator
Symbol.unscopables(): object Array.Symbol Returns an object whose properties have the value 'true'
concat(...items: ConcatArray<Value>[]): Value[] Array<Value> Combines two or more arrays.
concat(...items: T | ConcatArray<T>[]): Value[] Array<Value> Combines two or more arrays.
copyWithin(target: number, start: number, end?: number): this Array<Value> Returns the this object after copying a section of the array identified by start and end
entries(): IterableIterator<[number, Value]> Array<Value> Returns an iterable of key, value pairs for every entry in the array
every(callbackfn: (value: Value, index: number, array: Value[]) => unknown, thisArg?: any): boolean Array<Value> Determines whether all the members of an array satisfy the specified test.
fill(value: Value, start?: number, end?: number): this Array<Value> Returns the this object after filling the section identified by start and end with value
filter<S extends Value>(callbackfn: (value: Value, index: number, array: Value[]) => value, thisArg?: any): S extends Value[] Array<Value> Returns the elements of an array that meet the condition specified in a callback function.
filter(callbackfn: (value: Value, index: number, array: Value[]) => unknown, thisArg?: any): Value[] Array<Value> Returns the elements of an array that meet the condition specified in a callback function.
find<S extends Value>(predicate: (this: void, value: Value, index: number, obj: Value[]) => value, thisArg?: any): S extends Value | undefined Array<Value> Returns the value of the first element in the array where predicate is true, and undefined
find(predicate: (value: Value, index: number, obj: Value[]) => unknown, thisArg?: any): Value | undefined Array<Value>  
findIndex(predicate: (value: Value, index: number, obj: Value[]) => unknown, thisArg?: any): number Array<Value> Returns the index of the first element in the array where predicate is true, and -1
forEach(callbackfn: (value: Value, index: number, array: Value[]) => void, thisArg?: any): void Array<Value> Performs the specified action for each element in an array.
includes(searchElement: Value, fromIndex?: number): boolean Array<Value> Determines whether an array includes a certain element, returning true or false as appropriate.
indexOf(searchElement: Value, fromIndex?: number): number Array<Value> Returns the index of the first occurrence of a value in an array.
join(separator?: string): string Array<Value> Adds all the elements of an array separated by the specified separator string.
keys(): IterableIterator<number> Array<Value> Returns an iterable of keys in the array
lastIndexOf(searchElement: Value, fromIndex?: number): number Array<Value> Returns the index of the last occurrence of a specified value in an array.
map<U>(callbackfn: (value: Value, index: number, array: Value[]) => U, thisArg?: any): U[] Array<Value> Calls a defined callback function on each element of an array, and returns an array that contains the results.
pop(): Value | undefined Array<Value> Removes the last element from an array and returns it.
push(...items: Value[]): number Array<Value> Appends new elements to an array, and returns the new length of the array.
reduce(callbackfn: (previousValue: Value, currentValue: Value, currentIndex: number, array: Value[]) => Value): Value Array<Value> Calls the specified callback function for all the elements in an array.
reduce(callbackfn: (previousValue: Value, currentValue: Value, currentIndex: number, array: Value[]) => Value, initialValue: Value): Value Array<Value>  
reduce<U>(callbackfn: (previousValue: U, currentValue: Value, currentIndex: number, array: Value[]) => U, initialValue: U): U Array<Value> Calls the specified callback function for all the elements in an array.
reduceRight(callbackfn: (previousValue: Value, currentValue: Value, currentIndex: number, array: Value[]) => Value): Value Array<Value> Calls the specified callback function for all the elements in an array, in descending order.
reduceRight(callbackfn: (previousValue: Value, currentValue: Value, currentIndex: number, array: Value[]) => Value, initialValue: Value): Value Array<Value>  
reduceRight<U>(callbackfn: (previousValue: U, currentValue: Value, currentIndex: number, array: Value[]) => U, initialValue: U): U Array<Value> Calls the specified callback function for all the elements in an array, in descending order.
reverse(): Value[] Array<Value> Reverses the elements in an Array.
shift(): Value | undefined Array<Value> Removes the first element from an array and returns it.
slice(start?: number, end?: number): Value[] Array<Value> Returns a section of an array.
some(callbackfn: (value: Value, index: number, array: Value[]) => unknown, thisArg?: any): boolean Array<Value> Determines whether the specified callback function returns true for any element of an array.
sort(compareFn?: (a: Value, b: Value) => number): this Array<Value> Sorts an array.
splice(start: number, deleteCount?: number): Value[] Array<Value> Removes elements from an array and, if necessary, inserts new elements in their place, returning the deleted elements.
splice(start: number, deleteCount: number, ...items: Value[]): Value[] Array<Value> Removes elements from an array and, if necessary, inserts new elements in their place, returning the deleted elements.
toLocaleString(): string Array<Value> Returns a string representation of an array.
toString(): string Array<Value> Returns a string representation of an array.
unshift(...items: Value[]): number Array<Value> Inserts new elements at the start of an array.
values(): IterableIterator<Value> Array<Value> Returns an iterable of values in the array

Properties

Name Type Description
Array ArrayConstructor    

Inherited properties

Name Type Inherited from Description
length number Array<Value> Gets or sets the length of the array.

Defined in

Last Updated: 05 June, 2020