ImageIdOverride Interface
Rule that allows overriding default icon and dynamically define an icon for a particular node based on the context.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | undefined | string | Defines a condition for the rule, which needs to be met in order to execute it. | |
imageIdExpression | string | Defines an image ID that should be used for nodes that meet rule condition. | |
ruleType | ImageIdOverride | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Should this rule should be ignored if there is already an existing |
priority | undefined | number | RuleBase | Defines the order in which presentation rules will be evaluated and executed. |
Defined in
Last Updated: 13 June, 2024