getNodesCount Method
Retrieves nodes count.
getNodesCount(requestOptions: HierarchyRequestOptions<IModelConnection>, parentKey?: NodeKey): Promise<number>
Parameter | Type | Description |
---|---|---|
requestOptions | HierarchyRequestOptions<IModelConnection> | options for the request |
parentKey | NodeKey | Key of the parent node if requesting for child nodes count. |
Returns - Promise<number>
A promise object that returns the number of nodes.
Defined in
Last Updated: 13 June, 2024