UiAbstract Class
Entry point for static initialization required by various components used in the package.
Methods
Name | Description | |
---|---|---|
initialize(i18n: I18N): Promise<void> Static | Called by IModelApp to initialize the UiAbstract | |
terminate(): void Static | Unregisters the UiAbstract internationalization service namespace |
Properties
Name | Type | Description | |
---|---|---|---|
i18n Accessor StaticReadOnly | I18N | The internationalization service created by the IModelApp. | |
i18nNamespace Accessor StaticReadOnly | string | The internationalization service namespace. |
Defined in
Last Updated: 13 June, 2024