PropertyView<SS> Class

A React component that renders property as label/value pair

Extends

Methods

Name Description
constructor(props: PropertyViewProps): PropertyView    

Inherited methods

Name Inherited from Description
UNSAFE_componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
UNSAFE_componentWillReceiveProps(nextProps: Readonly<PropertyViewProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
UNSAFE_componentWillUpdate(nextProps: Readonly<PropertyViewProps>, nextState: Readonly<PropertyViewState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional ComponentLifecycle Catches exceptions generated in descendant components.
componentDidMount(): void Optional ComponentLifecycle Called immediately after a component is mounted.
componentDidUpdate(prevProps: Readonly<PropertyViewProps>, prevState: Readonly<PropertyViewState>, snapshot?: SS): void Optional NewLifecycle Called immediately after updating occurs.
componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
componentWillReceiveProps(nextProps: Readonly<PropertyViewProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
componentWillUnmount(): void Optional ComponentLifecycle Called immediately before a component is destroyed.
componentWillUpdate(nextProps: Readonly<PropertyViewProps>, nextState: Readonly<PropertyViewState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
forceUpdate(callback?: () => void): void Component<PropertyViewProps, PropertyViewState>  
getSnapshotBeforeUpdate(prevProps: Readonly<PropertyViewProps>, prevState: Readonly<PropertyViewState>): SS | null Optional NewLifecycle Runs before React applies the result of render to the document, and
setState<K extends undefined>(state: (prevState: Readonly<PropertyViewState>, props: Readonly<PropertyViewProps>) => null | S | object | null | S | object, callback?: () => void): void Component<PropertyViewProps, PropertyViewState>  
shouldComponentUpdate(nextProps: Readonly<PropertyViewProps>, nextState: Readonly<PropertyViewState>, nextContext: any): boolean Optional ComponentLifecycle Called to determine whether the change in props and state should trigger a re-render.

Inherited properties

Name Type Inherited from Description
context any Component<PropertyViewProps, PropertyViewState> If using the new style context, re-declare this in your class to be the
contextType Static undefined | Context<any> Component<PropertyViewProps, PropertyViewState> If set, this.context will be set at runtime to the current value of the given Context.
props undefined Component<PropertyViewProps, PropertyViewState>  
refs [key: string]: ReactInstance Component<PropertyViewProps, PropertyViewState>  
state Readonly<PropertyViewState> Component<PropertyViewProps, PropertyViewState>  

Defined in

Last Updated: 05 June, 2020